Hi, some months ago I upgraded from 12.04 to 14.04 and I had kodi 14 installed. I just upgraded kodi to 16 and now I can't install/remove/update anything. I looked it upa nd I can't understand how to fix it. Anyone can help? I'm familiar with linux since I've used it for quite some years now but I'm no expert.
carabott@MediaCentre:~$ sudo apt-get install kodi
Reading package lists... Done
Building dependency tree
Reading state information... Done
kodi is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
kodi-bin : Depends: libsdl2-2.0-0 (>= 2.0.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
carabott@MediaCentre:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libsdl2-2.0-0
The following NEW packages will be installed:
libsdl2-2.0-0
0 upgraded, 1 newly installed, 0 to remove and 18 not upgraded.
2 not fully installed or removed.
Need to get 0 B/317 kB of archives.
After this operation, 1,114 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 475813 files and directories currently installed.)
Preparing to unpack .../libsdl2-2.0-0_2.0.2+dfsg1-3ubuntu1_amd64.deb ...
Unpacking libsdl2-2.0-0:amd64 (2.0.2+dfsg1-3ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/libsdl2-2.0-0_2.0.2+dfsg1-3ubuntu1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0', which is also in package libsdl2:amd64 2.0.3+z4~20140315-8621-1ppa1precise1
Errors were encountered while processing:
/var/cache/apt/archives/libsdl2-2.0-0_2.0.2+dfsg1-3ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg retued an error code (1)
carabott@MediaCentre:~$
برچسب:
نویسنده: استخدام کار